PuTTy Problems

Or: please hold my hand, I’m dumb.

I’m interested in messing around with Ares as a coder, so I’m trying to install a copy of it on my computer. I’m cheap, you see. However, like all attempts to save money by doing it myself, I’m now paying in time and annoyance rather than money.

I’m running Windows 10 and following the instructions on the tutorial page. I’ve set up Ubuntu 16.04.6 on VirtualBox (which Windows 10 seems to hate - seriously, it was just one problem after another), and now I’m trying to connect via PuTTy. I’ve created the ports in the VM as instructed, but I can’t connect. PuTTy launches, displays a cursor that I can’t interact with in any way, and after about ten seconds I get a popup saying “Network error: connection timed out.” I don’t get any kind of security key message, as mentioned by the instructions.

I’m not sure what I’m doing wrong, and web searches are failing me. Any ideas, please?

P.S. I have very little experience with Real Computer Things (as opposed to weird little platform exclusive scripting languages like MUSHcode), so please take the amount of handholding you think I’ll need and then double it.

1 Like

My first guess would be some kind of firewall problem preventing you from connecting. Many firewalls don’t like the MUSH ports because they’re not part of any standard application so they look like malware.

To test this theory, you could try temporarily turning your windows firewall completely off and then trying to connect to your VM.

Don’t leave it that way, of course! :slight_smile: But it should help you narrow down whether it’s a firewall issue or some other kind of issue.

If it is the firewall, you can permit those specific MUSH ports.

1 Like

Thank you! I would like to say that this fixed the issue, but it sadly didn’t.

It occurred to me that I was trying to connect to the wrong IP. Attempting to connect to (and that is correct for the VM, I checked), even without the firewall, gives me the aforementioned connection error. Attempting to connect to results in “Network error: software caused connection abort.”

1 Like

localhost/ would try to connect to your own computer, so that’s not going to work.

When you set up networking on a VM, you basically give it its own IP address independent of your computer - that should be the address.

Just to confirm though… in your PuTTY connection screen, are you trying to use:

  • Host Name/IP:
  • Port: 22
1 Like

Yes, I am. (I thought that was the right thing to do, but when that didn’t work, I thought “well, maybe I’m just being really dumb” and tried the other one.)

thanks for your help, btw. I know this sort of troubleshooting can be incredibly frustrating, so I really appreciate the help, even if I can’t manage to solve this.

1 Like

Unfortunately I haven’t really used VirutalBox myself much, beyond the prototype to show that it worked when I wrote the VM instructions. I know that the key was the two steps (misnumbered as 1&2) after the IP config image in the article here, where you set up the network access and port forwarding. If you double check those steps and ruled out firewall issue, I’m afraid I’m stumped.

You could also try the ansible installer by @Mudpuppy. It’s not officially supported (I don’t know anything about ansible), but it might be worth a try if the other way isn’t working.

1 Like

Yeah, double checked everything, it’s still not working. I’m inclined to blame my own ignorance and Windows 10 (which seems to have some rather strict ideas on what I should and should not be doing with my own files on my own machine - this is not the first time it’s choked on something).

At this point, I think it’s just easiest to suck it up and spring for hosting. But thank you for the help!

1 Like