V0.57 Released

Beta V0.57 is released. There are a few new features, but mostly it contains fixes for some bugs reported this past week.

Release Notes
How to Upgrade

I suggest using the MU client upgrade/start and upgrade/finish commands this time. The web portal ‘upgrade’ button is much improved in this release, so you can use it next time.

Seems as though this broke PMs on the portal. You can still hit “new conversation” and send a PM, but it doesn’t let you interact other than that on the portal.


Everything’s still there in page/review. Nothing in the logs.

1 Like

Thanks. Grab latest master again and that should be fixed. (I’ll tag it as a new version once we see if anything else important got busted.)

1 Like

This is probably not an issue that only concerns v0.57. Somewhere, between 0.51 and 0.55 something must have changed in the webportal code, that doesn’t let me view aremush sites from my phone client anymore. I used to be able to view v0.51, of this I am pretty certain. Maybe others are having the same issue?

1 Like

The games I’ve tested work ok on my phone and tablet. Can you provide some more info please?

  • Which game.
  • Which phone client.
  • What’s the error?


The error is no error per se, I try to open the webpages and they load, but then they won’t display anything. It occurs when I try to open the following sites from Arescentral Directory:

Gray Harbor, Ares Demo, Star Trek Dreadnought Atlas, Mobile Suit Gundam and Spirit Lake

It works fine when I try to open the Chontio site, which is running on v0.43

I’ve tried this on both vBrowse and Safari. Same phenomenon.

I’m not sure what’s causing this, and it’s not repeating reliably:

2019-07-24 22:28:05 ERROR - Error in Web Request: client= error=undefined method split' for {"0"=>["Significant Other", "Childhood Friends"]}:Sinatra::IndifferentHash backtrace=["/home/ares/aresmush/plugins/profile/web/profile_save_request_handler.rb:54:inhandle’", “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:130:in block (2 levels) in on_web_request'", "/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:124:ineach’”, “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:124:in block in on_web_request'", "/home/ares/aresmush/engine/aresmush/error_block.rb:6:inwith_error_handling’”, “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:123:in on_web_request'", "/home/ares/aresmush/engine/aresmush/web/engine_api_server.rb:79:inblock in handle_request’”, “/home/ares/aresmush/engine/aresmush/error_block.rb:6:in with_error_handling'", "/home/ares/aresmush/engine/aresmush/web/engine_api_server.rb:71:inhandle_request’”, “/home/ares/aresmush/engine/aresmush/web/engine_api_server.rb:66:in `block in '”]

She got this error initially when she had a category in her relationships order prefs that she didn’t have anyone assigned to, then again when she put spaces in between the relationships. But now she has spaces in, and it’s fine. It will flash the error but still save the profile.

Sorry, it’s not the most reliable bug report. :frowning: I tried to replicate it, but I couldn’t make it happen no matter how many creative ways I tweaked things.

I think I know what’s causing it. Thanks for the report.

1 Like

It seems like temp rooms from deleted scenes are sticking around.

#R-2093 - RPR - Scene 2422 - Abandoned room from a deleted scene.

Do you happen to know if the scene was stopped before it was deleted?

ETA: I assume that’s it. The game command doesn’t let you delete an in-progress scene, but the web portal does. Will fix, thanks.

1 Like