V0.51 Released

Beta V0.51 is now released, with a few new features and fixes.

Release Notes
How to Upgrade

1 Like

This seems to have broken the drop-down menus. On GH and the Ares Demo.

1 Like

Did you run the database migrator? I forgot to do that on Ares Demo, so the menu was still using the old menu names. (page instead of route)

Actually I see the problem. I hadn’t forgotten to run the migrator, but the upgrade/finish is missing a load config step after the migrator is finished. I’ll fix that for the future. For now, though, doing load config should fix you up.

1 Like

I think I mentioned the cookie/here-cookie/scene thing, didn’t I? But mostly, thank you for the change! :slight_smile:

(A way to tell it to cookie anyone who joins later too would still be cool, but I can understand that being a pain since it’d have to keep track somehow.)

Oops - so you did. I corrected the release notes, thanks. (3-letter R name mixup :slight_smile: )

I understand the desire for cookie-ing proactively, but as you say - that’s just kind of problematic to implement. MUSH commands are instantaneous. To code one with memory for something it needs to do in the future would be a big pain, and - frankly - more trouble than cookies are worth. You can always cookie/scene a second time if somebody else joins to catch any stragglers.

1 Like

load config fixed it. Thank you! :slight_smile:

1 Like

Just noticed that people are allowed to spend Luck even when they have none. It leaves them sitting at 0.

1 Like

So I’ve upgraded a game to .51 and most of the menu drop downs are broken. Ran ‘load config’ did not help. The Admin menu works fine so I checked the website config file and all the names have been changed to ‘route’. I changed one back to ‘page’ and now the drop down menu works fine.

Oddly I upgraded a second game and everything works fine there. :confused:

The names were supposed to be changed to route. Are you sure your web portal was upgraded to 51 and not just the game? You might need to do a force-refresh in the browser to get the latest javascript reloaded.

I have force refreshed it and tried it on different browsers and different computers. The portal is still listed as version V0.48 though…

I’ve upgraded 3 different ares games and had 3 different results. All were from version .50.

1: Worked just fine. Game and portal both .51
2: Game updated but web portal did not.
3: Neither the game or the web portal will update.

If it helps when I run website/deploy I get this message.

%% Web portal deployed: yarn install v1.16.0
[1/5] Validating package.json…
[2/5] Resolving packages…
[3/5] Fetching packages…
info fsevents@1.2.4: The platform “linux” is incompatible with this module.
info “fsevents@1.2.4” is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@1.1.3: The platform “linux” is incompatible with this module.
info “fsevents@1.1.3” is an optional dependency and failed compatibility check. Excluding it from installation.
[4/5] Linking dependencies…
warning " > bootstrap@4.3.1" has incorrect peer dependency “popper.js@^1.14.7”.
error An unexpected error occurred: “EACCES: permission denied, mkdir ‘/home/ares/ares-webportal/node_modules/tap-parser/node_modules/js-yaml’”.
info If you think this is a bug, please open a bug report with the information provided in “/home/ares/ares-webportal/yarn-error.log”.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Missing yarn packages:
Package: bootstrap

  • Specified: ^4.3.1
  • Installed: 4.0.0

Package: js-yaml

  • Specified: ^3.13.1
  • Installed: 3.10.0

Package: fstream

  • Specified: ^1.0.12
  • Installed: 1.0.11

Run yarn to install missing dependencies.

Stack Trace and Error Report: /tmp/error.dump.de89f19dab2ff2aa2f70c9e2f06b4d44.log
An error occurred in the constructor for ember-cli-dependency-checker at /home/ares/ares-webportal/node_modules/ember-cli-dependency-checker

Done!

I’ve tried updating Yarn but it says it’s up to date.

It sounds like you’re having some kind of NPM (which is used by yarn) permission error. That’s a server-side issue that’s not really Ares specific. Not sure what could have caused it.

There are a variety of things you can try. I’d probably start with rebooting the server (not the game, the server itself) and if that doesn’t help you can try running yarn cache clean from your ares-webportal directory.

I still can’t get it to work. I recently upgraded to ubuntu 18.04, might that have something to do with it?

Ares works fine on 18.04, but it’s possible that the upgrade messed with something in your paths or permissions or something like that. It’s Digital Ocean’s upgrade scripts, so I’m afraid I really don’t know the specifics of what it does to the server.

The fsevent warnings are normal. It seems that your real error is this one: EACCES: permission denied, mkdir ‘/home/ares/ares-webportal/node_modules/tap-parser/node_modules/js-yaml If clearing the yarn cache didn’t help, you can also try just removing the node_modules directory entirely to let yarn start fresh.

cd ares-webportal
rm -rf node_modules
yarn install

Nope, same thing. Even tried creating an entirely new droplet and installing Ares fresh to see if I could just restore from a backup and the new install wouldn’t even launch. Got an error when trying to load the game.

My eyes are starting to cross so I’m gonna take a break and hit it fresh again in a few hours. Thanks for the help.

You got the same permission error even when node_modules wasn’t even there? That seems strange. Or was it a different error? Are you sure you’re running everything with the ares user and not root?

Definitely doing it as ares and not root. This is what I get when I try to install ares on a fresh droplet with Ubuntu.

2019-06-10 23:32:11 FATAL - Couldn’t start the game: error=no acceptor (port is in use or requires root privileges) backtrace=["/home/ares/.rvm/gems/ruby-2.6.0/gems/eventmachine-1.2.5/lib/eventmachine.rb:530:in start_tcp_server'", "/home/ares/.rvm/gems/ruby-2.6.0/gems/eventmachine-1.2.5/lib/eventmachine.rb:530:instart_server’", “/home/ares/aresmush/engine/aresmush/server.rb:31:in block in start'", "/home/ares/.rvm/gems/ruby-2.6.0/gems/eventmachine-1.2.5/lib/eventmachine.rb:194:inrun_machine’”, “/home/ares/.rvm/gems/ruby-2.6.0/gems/eventmachine-1.2.5/lib/eventmachine.rb:194:in run'", "/home/ares/aresmush/engine/aresmush/server.rb:22:instart’”, “/home/ares/aresmush/engine/aresmush/bootstrapper.rb:72:in start'", "/home/ares/aresmush/Rakefile.rb:27:inblock in <top (required)>’”, “/home/ares/.rvm/gems/ruby-2.6.0/gems/rake-12.3.0/lib/rake/task.rb:251:in block in execute'", "/home/ares/.rvm/gems/ruby-2.6.0/gems/rake-12.3.0/lib/rake/task.rb:251:ineach’”]
2019-06-10 23:32:11 WARN - Abnormal shutdown. See if there are any errors above.

  • I’m actually having a terrible allergy/pollen day and can barely see. Gonna take an antihistamine, shower, eat dinner, and try again in a bit. I’m sure it’s me, I’m sure I’m doing something wrong, I just can’t figure out what.

OK that’s a different error than what you were getting before. That one means that either:

a) The game is already running (seems unlikely in your case but I figured I’d mention it) or
b) The hostname that you’ve entered in server.yml is not accessible by the droplet. Typically this happens when the DNS hasn’t been updated yet or the IP is incorrect, which could be happening because you’ve moved to a new droplet.