V0.47 Released

Beta V0.47 is now released. It contains a bunch of new features and fixes for recent bug reports.

This version requires a game restart due to some engine fixes.

Release Notes

How to Upgrade

I love this custom approval stuff. Thank you for adding it! :smiley:

I’m seeing it in-game using app and when I do an app review on the portal as an admin, but I don’t see it when I run a Testguy through Chargen. I tried throwing:

{{#if model.custom}}
{{{ansi-format text=model.custom}}}
{{/if}}

Into the chargen-review.hbs, but that doesn’t seem to have solved it. Any way of getting it into the portal app review for chargen?

Edit

Never mind. Found what was missing. I added:

    custom_review = Chargen.custom_app_review(char)
    custom_app = custom_review ? MushFormatter.format(custom_review) : nil

and

      custom: custom_app,

To chargen_review_request_handler.rb and now it’s there. :smiley:

1 Like

Oh, and someone just reported this:

If you change the location of a scene via the portal, you get an error and end up with a massive thing like “Thread::Queue:0x0000000002a36c98” at the bottom of your scene. It’s a link but doesn’t go anywhere real. I assume this is a thing for Faraday but you guys might want to be the ones to report it, I’m not sure.

Found this in the error log:

2019-04-28 15:18:33 ERROR - Error in Web Request: client= error=undefined method gsub' for # backtrace=["/home/ares/aresmush/engine/aresmush/formatters/mush_formatter.rb:8:informat’", “/home/ares/aresmush/plugins/website/helpers/formatting.rb:17:in format_output_for_html'", "/home/ares/aresmush/plugins/website/helpers/formatting.rb:6:informat_markdown_for_html’”, “/home/ares/aresmush/plugins/scenes/helpers.rb:510:in build_scene_pose_web_data'", "/home/ares/aresmush/plugins/scenes/public/scenes_api.rb:32:inadd_to_scene’”, “/home/ares/aresmush/plugins/scenes/web/change_scene_location_handler.rb:32:in handle'", "/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:130:inblock (2 levels) in on_web_request’”, “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:124:in each'", "/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:124:inblock in on_web_request’”, “/home/ares/aresmush/engine/aresmush/error_block.rb:6:in `with_error_handling’”]

1 Like

The output for detail/edit is incorrect: detail/set here/Detail=Whatever should be detail/set here=Detail/Whatever

1 Like