V0.106 Released

Beta V0.106 has been released:

Release Notes

Please pay special attention to the upgrade notes - as there are some extra steps required for this update.

So I fired up a new install of v0.106 and I’m having an issue where when I go to any Config file through the web portal I’m getting the Confirm Restore dialogue box. The config files all seem to be there, I confirmed that, but the web portal wants to restore any one I click on. Once that dialogue comes up it sort of freezes the entire web portal. I have to re-type the website address to get back into things.

Just wondering if this is a bug or if the install went screwy somewhere?

Thanks for letting me know. So the config controller apparently got deleted somehow. No idea how that happened. I’ll make a hotfix. If you’re in a rush, you can just recreate the file from the contents here: ares-webportal/config.js at acb659622cec77f6716569350aa04ffc87fee5b1 · AresMUSH/ares-webportal · GitHub

1 Like

No rush but thanks. :slight_smile:

On an updated game now I’m getting a server mismatch on the web portal.

AresMUSH game v0.106, portal v0.105

I tried restarting the game, redeploying the portal, clearing my cache, and having other players log onto it and they’re all reporting the same.

I did get a message saying my NPM needed to be updated while the upgrade was happening.

Required packages are missing, run npm install from this directory to install them.

That was the error.

Did you run the special upgrade script?

I did.

This came up a lot too:

Did you mean? unified_play_screen=
2022-04-11 18:31:19 WARN - Model AresMUSH::Character failed to respond to unifie d_play undefined method `unified_play=’ for #<AresMUSH::Character:0x000055b8ff5c 4be0>

Just to be clear, that error came up a number of times it looks like once for each character.

OK - the unified_play thing is a separate issue unrelated to anything else.

Did you get any errors when you ran the special NPM upgrade script? Maybe try running it again - it sounds like something with your NPM install went awry.

So I re-ran the npm-update and it seems to have updated fine. I get an error saying I should update NPM when I restart the game, however. When I try to do that I get this:

npm ERR! Cannot read property ‘resolve’ of null

npm ERR! A complete log of this run can be found in:
npm ERR! /home/ares/.npm/_logs/2022-04-11T19_36_27_485Z-debug-0.log
Required packages are missing, run npm install from this directory to install them.

What is the error you get about updating NPM? The update_npm script should have done that so it seems like something is going awry somewhere.

Here’s a screenshot of everything that came up with the update_npm.

So down near the bottom it says “killed” - which means something went awry before it finished successfully.

Often on Ares droplets that means running out of memory, which can be fixed by a droplet restart, but I dunno if that’s the case here.

You could also try opening up the update_npm script and individually running the commands in there one by one. That might gain some insight into why it’s failing.

If you get stuck you can PM me the login info for the shell and I can see if I can figure out why it’s unhappy. NPM is a separate tool, but Ares relies on it to work.

Ok. I’ll give running each command separately a try. Thanks. :slight_smile:

Well, now nothing seems to work.

I tried running each command separately and it all seemed to go okay but now the game won’t launch. It says check the highest numbered log but that log hasn’t been updated in over 20 minutes.

I did upgrade my DO droplet to 2GB of RAM. Not sure if that would have affected anything but now I’m at a total loss.

I made some changes - anyone who was having issues deploying the portal can try running the special upgrade steps again.

  1. Type upgrade/start in-game to begin the upgrade.
  2. Use the shutdown command in-game or Admin → Manage → Shutdown from the web portal to shut down the game. (See Shutting Down the Game for help.)
  3. Log into the server shell and run the following commands:
cd ~/ares-webportal
bin/update_npm
cd ~/aresmush
bin/startares

Well, this seems to have taken care of some of the problems(I can access config files again) but now I’m getting a version mismatch between the web portal(v0.107) and the game(v0.106).

It could be a cache issue. Try in an incognito window or try the version command on the client to see what version it thinks it is.

I rebooted the droplet and that took care of it. Sorry about that.

1 Like