Trouble Displaying Emojis

If a player is having trouble seeing emojis, and it just turns out as gibberish, make sure they have Unicode (UTF8) enabled in their MUSH client. Most of the main modern MU clients support unicode, but not all of them have it enabled by default.

Instructions for many clients can be found here:

If your client is not listed and you figure it out, let me know and I’ll be glad to add more clients to the instructions.

If your client does not support unicode (e.g., SimpleMU) or you just want to turn off special characters in general - you can turn them off with the ascii command. ascii on. You can also set this preference for all linked handle characters in your AresCentral account settings.

1 Like

Will this turn off umlauts and the like, as well? I like those sorts of special characters, and my client (BeipMU) supports unicode, but I really dislike emojis.

Thanks either way!

1 Like

Yes, it will turn off all non-ASCII characters, and ASCII does not support umlauts and the like.

Is there a way to change how clients represent the emojis, then? Emojis are the same size as my text, which means I can’t make out what kind of face it’s making, or what the emoji might be. I’m using BeipMU, but not sure if all clients are like this?

That’s up to the client. Emojis are just unicode characters, the same as other non-ascii characters like á or ü. How they get displayed is a client thing - Ares just tells it what character they are.

Is the client able to know what ‘kind’ of unicode it is? Emojis need to be large, but umlauts don’t.

Yes, the range of unicode characters for emoji is defined in the unicode standard, so a client could differentiate between emoji and non-emoji if they wanted. Ares has no control over font, size, etc. on the client side.

ETA: Though I don’t know if MU clients are set up to support multiple font sizes on a single line.

Just to throw an update on here, for those who ended up at the same place I did and didn’t think to look at the release notes: Emoji display can be disabled in the emoji.yml file without disabling the accented characters.


To clarify - that disables them at the game level for everyone. The ascii command disables them on an individual basis.