Game Issues After HTTPS Install

So I saw there was a new, simplified, HTTPS install procedure and I wanted to check it out.

Everything seems to run okay until the reboot. The game never came back up. I restarted the droplet, and the game came back up but the site was unreachable(connection refused), then suffered an abnormal shutdown.

I restarted the game again, it came back up, the site was still unreachable(connection refused), then suffered an abnormal shutdown again.

I restarted the server again and the game is up and has been for about 34 minutes now but the site remains unreachable(connection refused).

Any ideas if this is a bug or something I did wrong? Thanks.

Check your game/config/server.yml file and make sure that the use_https flag is set to true. That’s the only thing within the game itself that deals with HTTPs.

If that’s not it, it’s possible that something went awry on the letsencrypt or nginx side. That’s outside Ares / outside my control, but I can still try to give you some steps to troubleshoot.

Yeah, it’s set to yes. The problem is, for the sake of having a control. I set up a game using the old system and it worked fine. It’s just this new system where you simply run a script that seems to be an issue.

I went and ran the certbot command manually and everything is working fine now it seems.

The old way had a script too - bin/certs.

I just added two things to that script that used to be done manually:

  • It runs the sudo certbot command for you
  • It updates the use-https flag for you

Sounds like it was the first one that went awry. Do you still have the command history and output to see what the script originally told you, or was that lost to reboots?

Could’ve been something as simple as a typo in the hostname provided to the certbot command.

Unfortunately, I don’t. :frowning: I’m sure that’s what it was, though, a slip of the fingers or something. I really do like this simplified process, though. It’s very slick. :slight_smile:

1 Like

So I tried another new install just to try it again and I encountered the same issues. So when I type ‘bin/certs’ in the aresmush directory it prompts me for the domain and that’s it. It never asks for my email address or for me to agree to the TOS. It could be wrong but it doesn’t seem to actually be installing cerbot. I had to manually install it when I tried to do it the old way.

When you say you had to manually install certbot - do you mean just running sudo certbot or do you mean actually installing it? The standard installer should have certbot pre-installed and ready to go, and the bin/certs script runs sudo certbot --nginx -d $HOST_NAME so I dunno what’s up.

I ran bin/certs and it went through a bunch of stuff(but it never prompted me for my email or to agree to the TOS). When it was done I rebooted the server and then the web portal kept refusing the connection.

When I tried to run sudo certbot --nginx it said certbot was not installed.

Oh! I see what’s happened. The install script I use for easy mode is subtly different from the self-install. Easy mode has certbot pre-installed but self-install doesn’t. Will fix. Thanks.

Ahhh. Nice. Glad I could help. :slight_smile:

1 Like