Error Using 1-Click Droplet Install

So, I set the droplet up, signed in to it and ran the ./ script. It gets to the point of starting the game, errors out, and tells me to check the log. I get this:

2023-01-12 16:13:58 FATAL - Couldn’t start the game: error=no acceptor (port is in use or requires root privileges) backtrace=[“/home/ares/.rvm/gems/ruby-3.1.2/gems/eventmachine-1.2.7/lib/eventmachine.rb:531:in start_tcp_server'", "/home/ares/.rvm/gems/ruby-3.1.2/gems/eventmachine-1.2.7/lib/eventmachine.rb:531:in start_server’”, “/home/ares/aresmush/engine/aresmush/server.rb:31:in block in start'", "/home/ares/.rvm/gems/ruby-3.1.2/gems/eventmachine-1.2.7/lib/eventmachine.rb:195:in run_machine’”, “/home/ares/.rvm/gems/ruby-3.1.2/gems/eventmachine-1.2.7/lib/eventmachine.rb:195:in run'", "/home/ares/aresmush/engine/aresmush/server.rb:22:in start’”, “/home/ares/aresmush/engine/aresmush/bootstrapper.rb:72:in start'", "/home/ares/aresmush/Rakefile.rb:27:in block in <top (required)>'”, “/home/ares/.rvm/gems/ruby-3.1.2/gems/rake-12.3.3/lib/rake/task.rb:273:in block in execute'", "/home/ares/.rvm/gems/ruby-3.1.2/gems/rake-12.3.3/lib/rake/task.rb:273:in each’”]
2023-01-12 16:13:58 WARN - Abnormal shutdown. See if there are any errors above.

So, I have re-built the whole droplet, I’ve just re-installed, I’ve tried 7 different ports in all. And no matter what I do or don’t do, I get the error above. I’m following the instructions as given. Is there something I’m doing wrong on this? I verified that the last port I gave it should be unused.

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 882/redis-server 12
tcp 0 0* LISTEN 13136/nginx: master
tcp 0 0* LISTEN 13218/systemd-resol
tcp 0 0* LISTEN 863/sshd: /usr/sbin
tcp 0 0 ESTABLISHED 36470/sshd: root@no
tcp 0 64 ESTABLISHED 1714/sshd: root@pts
tcp 0 0 TIME_WAIT -
tcp 0 0 TIME_WAIT -
tcp 0 0 TIME_WAIT -
tcp6 0 0 ::1:6379 :::* LISTEN 882/redis-server 12
tcp6 0 0 :::80 :::* LISTEN 13136/nginx: master
tcp6 0 0 :::22 :::* LISTEN 863/sshd: /usr/sbin
udp 0 0* 13218/systemd-resol

None of the ports I tried are there. Is there something stupidly obvious that I’m missing?

Thank you!

It’s probably nothing to do with the port itself. The most common reason that error happens is when you don’t have your hostname DNS set up yet, or it hasn’t had time to propagate to the droplet. Are you using an IP or hostname?

Verified via a ping and nslookup that the domain is returning the correct IP. Rebuilt. Same error. Has a static IP. Using DO’s nameservers. Are there any other logs I should be looking at?

Just to confirm - you did the nslookup from the server shell (not just from your PC)?

I’m not actually familiar with DO’s domain hosting - I’ve always used something like namecheap or godaddy (there are instructions for namecheap here: Setting Up A Custom Domain with Namecheap - AresMUSH Maybe there’s some missing setting.

There’s also a firewall. You can turn that off temporarily using sudo ufw disable. I don’t recommend leaving it that way, but it might help to rule out the possibility of a firewall misconfiguration.

Starting the game in debug mode with bin/devstart can give some additional insight into startup errors, but I doubt it will be helpful in this case. Maybe worth a try though.

If none of that helps, you’re welcome to PM me the IP and ares password and I can take a look.

We got this server sorted out.

One other game had a similar 1-click error caused by using the 1GB droplet size instead of the required 2GB droplet. The setup failed halfway through because of an out-of-memory error.

If anyone else has any issues with the 1-click installer, some tips:

  1. Verify that you’re using the 2GB droplet.
  2. If you need to abort or it fails midway through or something, you should delete the old droplet and create a new one. The installer isn’t meant to be run multiple times.

If you still have issues, please capture the entire server shell output and PM or email it to me so I can maybe figure out what’s wrong.