Error in Ares Web Portal PM

So a new player tried to start a PM with me via the web today and it threw an error. I was able to PM him via the web and then everything worked fine. He says the drop-down menu is blank for selecting a character to PM. This is the error I get from the log.

2020-05-19 20:12:05 ERROR - Error in Web Request: client= error=undefined method each' for nil:NilClass backtrace=["/home/ares/aresmush/plugins/page/web/send_page_request_handler.rb:21:in handle’", “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:145:in block (2 levels) in on_web_request'", "/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:139:in each’”, “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:139:in block in on_web_request'", "/home/ares/aresmush/engine/aresmush/error_block.rb:6:in with_error_handling’”, “/home/ares/aresmush/engine/aresmush/commands/dispatcher.rb:138:in on_web_request'", "/home/ares/aresmush/engine/aresmush/web/engine_api_server.rb:89:in block in handle_request’”, “/home/ares/aresmush/engine/aresmush/error_block.rb:6:in with_error_handling'", "/home/ares/aresmush/engine/aresmush/web/engine_api_server.rb:81:in handle_request’”, “/home/ares/aresmush/engine/aresmush/web/engine_api_server.rb:66:in `block in class:EngineApiServer’”]
2020-05-19 20:12:05 ERROR - Unhandled web request: {“cmd”=>“sendPage”, “api_key”=>“1a8045e5-7d6f-45c5-94af-723e41211411”, “auth”=>{“authenticator”=>“authenticator:ares”, “token”=>“696ac001-49e2-4a34-a580-17fd5564968e”, “name”=>“William”, “id”=>“46”, “is_approved”=>“true”, “is_admin”=>“false”, “is_coder”=>“false”}}.
2020-05-19 20:12:08 DEBUG - AresMUSH::Who::WhoCmd: ID=51 Enactor=Transformers Cmd=WHO
2020-05-19 20:12:17 DEBUG - AresMUSH::Profile::ProfileCmd: ID=51 Enactor=Transformers Cmd=profile william

1 Like

Is the dropdown blank for anybody else, or just that one person? Can you reproduce it with a new character? I’m not seeing the blank dropdown issue on my test games.

Though yes, if you do try to send a page to nobody, you get that error instead of a more sensible “You can’t send a page to nobody” message.

I haven’t had the issue myself. I had another player try and they were able to send the PM fine.

1 Like

OK thanks for checking.

I’m the person, btw.

The drop down is blank on all my devices, and also when I logged in as a friend’s account. I figured out what @ZombieGenesis meant so I can type in a full name, hit enter, and it will start a conversation, but the drop down is still blank.

It does work on every other Ares game I play.

How it appears to me:

Edit to add: @BearNecessities has the same issue with the drop-down not appearing.

1 Like

FWIW I tried from both my mobile device and my computer and the drop down menu didn’t work. I could however input a character’s name, press enter, and start a conversation. It’s just the drop down menu that doesn’t seem to be populating.

1 Like

It appears to be something in my CSS>

.ember-basic-dropdown-content {
position: absolute;
width: auto;
z-index: 1000;
background-color: #C00000;
text-field: green;

1 Like

I think I fixed it. The z-index seems to have been too small.

1 Like

So it’s working now?

Yep. Refreshed the CSS and good-to-go. :slight_smile:

1 Like

It seems to be, yup.

1 Like