Discord->Game Messages Blank

Discord changed their permissions management so bots now need express permission to receive message content. This will result in discord–>to–>game messages showing up blank.

To fix this:

  1. Log in to the Discord Developer Portal.
  2. Select your Ares bot.
  3. Select “Bot”.
  4. Enable the slider under “Message Content Intent.”

Note: This doesn’t appear to have rolled out to every discord server yet (just started going into effect yesterday) but it will eventually.

Thx to ZombieGenesis for letting me know it was busted.

You may also need to restart the discord bot (as you would during an upgrade, or you can just reboot the entire server) after making this change.