Compile error after server upgrade

Bizarrely, I get this error on one character but not another. Picking it up any time I try to use the webportal for either ‘play’, or to view a scene the character is in. I can’t identify why the hell this works for one character but not the other two. Similar issue reported by other players. Some characters can use the webportal, some get an unspecified error (blank on page, this from the Chrome or Edge console)

Error: Compile Error: Unexpected Helper isApproved @ 0…0
at unwrapHandle (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:79383)
at JitVM.compile (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:77773)
at Object.evaluate (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:74422)
at AppendOpcodes.evaluate (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:73723)
at LowLevelVM.evaluateSyscall (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:76652)
at LowLevelVM.evaluateInner (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:76608)
at LowLevelVM.evaluateOuter (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:76600)
at (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:77606)
at JitVM.execute (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:77583)
at TryOpcode.handleException (vendor-dc3bb98a7568dbc71da1105f8aff7472.js:76801)

By server upgrade - do you mean major server version change? e.g. 18.04 to 20? I’m assuming so for the rest of this…

When you make any major change to the server, it can affect the infrastructure on which Ares resides. For instance, a change in the gcc compiler can make your installed ruby gems no longer function properly. An upgrade to redis can overwrite your database settings. This is not really Ares specific. You see the same thing when apps break as a result of OS upgrades. The automatic security updates don’t generally cause any problems, but major upgrades can cause you serious headaches.

Ruby gems are the most common thing that affects Ares, and since different gems are used in different parts of the code, the effects can be unpredictable.

You can try restarting your game engine (described here) and see if that helps.

If you continue to get gem-related errors, you can try running: bundle install from the aresmush directory.

If that still doesn’t help, you might need to do a rvm reinstall <ruby version>. (2.6.3 is the default version that’s installed on easy mode systems, but Ares runs on 2.7 fine too)

You may even need to wipe out your RVM directory to start fresh: rm -rf ~/.rvm

You may see similar issues installing/upgrading the web portal, in which case try removing the tmp and node-modules directories from within ares-webportal.

I should have clarified, sorry. No, not a major upgrade, only a security upgrade (still on Ubuntu 18.04.3). It may have nothing to do with it whatsoever, but it’s the only thing that’s changed that I can identify from Before Errors Started to After Errors Started ™.

Have tried a game restart (and upgrade which I’d previously held off in case that proved more of a problem), have tried bundle install, tried renaming node-modules and redeploying the web portal (renamed because I’m too chicken to remove directories). Also reinstalled ruby.

I’ve basically rebooted everything I can think of and still no joy. The thing that’s confusing me is that this is an error with some characters and not others, and I can’t identify a difference between them.

I’m open to any further suggestions?

For the sake of closure, I don’t know the fuck why, but apparently sharing a scene the affected characters were in has fixed the error.

I’m completely convinced it’s just voodoo. No other explanation.

Straaange. Yeah that doesn’t seem like something that would be related to the security updates - I just saw “server upgrade” and thought maybe it was the same as those other situations in the last few days. :slight_smile:

I mean it could be a bug? isApproved is actually a function in the code. But I’m not seeing anything wrong with it on the play screen, or any reason why it would behave differently for one char vs. another.

If it happens again, let me know and I can take a closer look at the scene and characters involved.

1 Like

Welp… it happened again. Scene created (via web portal), pose put into it and then bam, same error. Neither character can get into this new scene via the webportal (Picard facepalm, same error message as before) or talk on channel via the webportal. Can scene on the client just fine.

So that narrows it down to definitely something with the scene, maybe the scene/create. I mean, I don’t THINK I broke anything there, but I’m also not very bright as well you know, so… any thoughts?

Do you have any custom code, particularly on the portal side?

Could you PM me the scene and the players involved (who gets the error, who doesn’t get the error) so I can see if there’s a common thread?